Cloudflare API Outage Causing Downtime In Some Circumstances
Incident Report for Prisma Data Platform
Resolved
All services have been fully restored. More information about the Cloudflare outage itself can be found here: https://blog.cloudflare.com/post-mortem-on-cloudflare-control-plane-and-analytics-outage/
Posted Nov 04, 2023 - 04:25 UTC
Update
Accelerate remains mostly functional for customers from what we are able to observe. We are continuing to monitor the situation with Cloudflare.

We continue to recommend against uploading new schemas or deploying changes to your queries.
Posted Nov 03, 2023 - 17:14 UTC
Monitoring
The majority of Accelerate functionality has returned to service. We are continuing to monitor, however our observability is limited due the ongoing Cloudflare outage. For that reason, we still recommend that you refrain from updating your Prisma schema.
Posted Nov 03, 2023 - 09:52 UTC
Identified
The issue has been identified and a fix is being implemented.

Some Cloudflare services are still being recovered and creating new Accelerate projects or generating new API keys are still impacted.
Posted Nov 03, 2023 - 07:26 UTC
Investigating
Description: The Cloudflare API is experiencing an outage causing failures in query engine orchestration.

Affected users: Customers attempting to start a new query engine would be unable to do so.

Root cause: https://www.cloudflarestatus.com/

Workarounds: Investigating

**Recommendation**: Please refrain from updating your Prisma schema. Updates to the Prisma Schema require a start of a new Query Engine which is not working right now. Keep your schema as is and your workloads won't be affected.
Posted Nov 02, 2023 - 11:54 UTC
This incident affected: Prisma Accelerate.