Degraded performance in US East

Incident Report for Prisma Data Platform

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 17:25 UTC

Monitoring

A fix has been rolled out and US East is now operational. We're continuing to monitor.
Posted Mar 27, 2026 - 15:34 UTC

Identified

Description: We have identified an issue degraded performance in the US East region and are working to implement a fix.

Affected users: US East

Root cause: The cause has already been identified and we're implementing a fix.

Workarounds: None identified
Posted Mar 27, 2026 - 15:23 UTC

Investigating

Description: We have identified an issue degraded performance in the US East region and are working to implement a fix.

Affected users: US East

Root cause: Currently unknown

Workarounds: None identified
Posted Mar 27, 2026 - 15:19 UTC
This incident affected: Prisma Postgres.